#koha: Development IRC meeting 29 May 2024

Meeting started by paulderscheid[m] at 14:00:16 UTC (full logs).

Meeting summary

  1. Introductions (paulderscheid[m], 14:00:30)
    1. Paul Derscheid, LMSCloud GmbH, Germany (paulderscheid[m], 14:00:45)
    2. Owen Leonard, Athens County Public Libraries, Ohio, USA (oleonard, 14:01:34)
    3. Caroline Cyr La Rose, inLibro, Montréal, Québec, Canada (caroline, 14:01:57)
    4. Matt Blenkinsop, PTFS Europe, UK (MatthewBlenkinsop[m], 14:03:06)
    5. Katrin Fischer, BSZ, Germany (cait, 14:04:00)
    6. Thomas Dukleth, Agogme, New York City (thd, 14:04:06)
    7. Lisette Scheer, ByWater Solutions (lisette, 14:04:31)
    8. Nick Clemens, BWS (kidclamp, 14:04:59)
    9. Tomas Cohen Arazi (tcohen, 14:06:07)
    10. Kyle Hall, ByWater Solutions (khall, 14:06:38)

  2. Announcements (paulderscheid[m], 14:06:54)
    1. koha 24.05 just released (paulderscheid[m], 14:07:30)

  3. Update from the Release manager (24.05) (paulderscheid[m], 14:08:36)
    1. roadmap page + email will be coming this week or early next week for the next cycle (paulderscheid[m], 14:09:25)
    2. current release maintainers are going to continue until the next security release (paulderscheid[m], 14:10:44)

  4. Updates from the Release Maintainers (paulderscheid[m], 14:11:03)
  5. Updates from the QA team (paulderscheid[m], 14:11:43)
    1. CSRF bugs still need attention (paulderscheid[m], 14:12:54)
    2. https://annuel.framapad.org/p/koha_34478_remaining (kidclamp, 14:13:42)

  6. Status of roadmap projects (paulderscheid[m], 14:15:27)
    1. https://wiki.koha-community.org/wiki/Road_map_24.05 (paulderscheid[m], 14:15:44)
    2. not much change, port open projects to next roadmap (paulderscheid[m], 14:15:53)
    3. next roadmap will be split into: big community projects, advertised projects (paulderscheid[m], 14:16:21)

  7. Actions from last meeting (paulderscheid[m], 14:17:03)
    1. ACTION: paulderscheid file an issue for integrating JS15 into QA scripts (paulderscheid[m], 14:17:48)
    2. https://wiki.koha-community.org/wiki/Release_maintenance#Backporting_a_patch_with_a_new_perl_dependency new dependency workflow proposal (cait, 14:19:34)
    3. ACTION: tcohen give some feedback on proposed workflow for dependencies (paulderscheid[m], 14:20:16)
    4. ACTION: put tombstone table pattern on the roadmap for discussion for next cycle (paulderscheid[m], 14:20:36)
    5. ACTION: ashimema to add a qa script check for NOTICE1 in the coding guidelines (paulderscheid[m], 14:20:59)
    6. https://wiki.koha-community.org/wiki/Release_management#Dependency_changes corrected link to workflow proposal (cait, 14:21:15)

  8. General development discussion (trends, ideas, ...) (paulderscheid[m], 14:21:37)
  9. Review of coding guidelines (paulderscheid[m], 14:25:38)
    1. ACTION: kidclamp to write a coding guideline for bug 36246 (paulderscheid[m], 14:26:22)

  10. Any other business (paulderscheid[m], 14:26:44)
    1. https://kb.test.koha-community.org (paulderscheid[m], 14:28:05)
    2. tcohen added a new tool to document infrastructure related things, that might contain sensitive information (paulderscheid[m], 14:28:40)
    3. tcohen wants help to structure the aforementioned knowledge base (paulderscheid[m], 14:28:59)

  11. Set time of next meeting (paulderscheid[m], 14:29:56)
    1. Next meeting: 12 June 2024, 14 UTC (paulderscheid[m], 14:33:57)


Meeting ended at 14:34:28 UTC (full logs).

Action items

  1. paulderscheid file an issue for integrating JS15 into QA scripts
  2. tcohen give some feedback on proposed workflow for dependencies
  3. put tombstone table pattern on the roadmap for discussion for next cycle
  4. ashimema to add a qa script check for NOTICE1 in the coding guidelines
  5. kidclamp to write a coding guideline for bug 36246


Action items, by person

  1. kidclamp
    1. kidclamp to write a coding guideline for bug 36246
  2. tcohen
    1. tcohen give some feedback on proposed workflow for dependencies
  3. UNASSIGNED
    1. paulderscheid file an issue for integrating JS15 into QA scripts
    2. put tombstone table pattern on the roadmap for discussion for next cycle
    3. ashimema to add a qa script check for NOTICE1 in the coding guidelines


People present (lines said)

  1. paulderscheid[m] (31)
  2. mbridge (5)
  3. huginn` (4)
  4. cait (3)
  5. kidclamp (2)
  6. tcohen (2)
  7. oleonard (1)
  8. MatthewBlenkinsop[m] (1)
  9. khall (1)
  10. lisette (1)
  11. caroline (1)
  12. thd (1)


Generated by MeetBot 0.1.4.