#koha: Development IRC meeting 3 April 2024

Meeting started by cait at 11:59:29 UTC (full logs).

Meeting summary

  1. Introductions (cait, 11:59:40)
    1. https://wiki.koha-community.org/wiki/Development_IRC_meeting_3_April_2024 Agenda (cait, 11:59:50)
    2. Katrin Fischer, BSZ, Germany (cait, 12:00:36)
    3. Paul Derscheid, LMSCloud GmbH, Germany (paulderscheid[m], 12:00:50)
    4. Tomas Cohen Arazi (tcohen, 12:02:47)
    5. Emmi Takkinen, Koha-Suomi Oy, Finland (EmmiTakkinen[m], 12:02:54)

  2. Announcements (cait, 12:03:40)
    1. Hackfest in Marseille is next week! (cait, 12:03:53)
    2. thd might have a fix for the email issues with the wiki (cait, 12:05:08)
    3. Emily Lamancusa, MCPL, USA (emlam, 12:08:28)

  3. Update from the Release manager (cait, 12:09:50)
  4. Updates from the Release maintainers (cait, 12:11:12)
    1. RM will try to empty queue as much as possible before next week, lots of QA has been done over Easter holidays (cait, 12:11:35)
    2. Release should happen today! (cait, 12:12:05)

  5. Updates from the QA team (cait, 12:12:32)
    1. Nick Clemens, ByWater Solutions (kidclamp, 12:12:52)
    2. QA queue is pretty full, please QA! (cait, 12:14:00)

  6. Status of roadmap projects (cait, 12:15:10)
    1. tcohen working on the holds table merge (reserves, old_reserves) (cait, 12:15:51)
    2. tcohen will be testing a new pipeline for building ktd images on gitlab (cait, 12:16:42)

  7. paulderscheid[m] using SMTP settings from HKS3 now for the Discourse project. Stuck on not being able to use DKIM which creates a problem sending to Google/Outlook (cait, 12:22:00)
    1. ACTION: paulderscheid[m] and thd to figure out if the same mail solution as for the wiki can be used (cait, 12:23:20)
    2. ACTION: cait to set a date for moving master to main after the hackfest (trying not to break workflows right now) (cait, 12:28:15)
    3. bugs with easy to re-do notices in TT are marked with Academy (cait, 12:29:50)
    4. TT switch: items.fine and some custom parameters need to be figured out in the code (cait, 12:31:10)

  8. Security bugs and news (cait, 12:32:00)
    1. Evelyn and Tomas to contact german company offering static code analysis with Perl support (tcohen, 12:35:39)
    2. API still needs some CSRF work (cait, 12:36:56)

  9. Actions from last meeting (cait, 12:37:25)
    1. No actions from last meeting! (cait, 12:37:31)

  10. General development discussion (cait, 12:37:48)
    1. tcohen's proposal for REST API: Make our returns consistent when something doesn't exist (cait, 12:38:34)
    2. We are leaning towards having specific returns: patron X doesn't exist etc. (cait, 12:40:11)
    3. tcohen's review turned up a lot of inconsistencies to work on (cait, 12:41:23)

  11. Reviewof coding guidelines (cait, 12:45:17)
    1. ACTION: tcohen to write a guildeline for the API returns when work has gone through QA (cait, 12:46:08)

  12. Any other business (cait, 12:46:38)
  13. Set time of next meeting (cait, 12:52:19)
  14. KohaCon24 (cait, 12:53:02)
    1. CfP and workshops is still open until end of April (cait, 12:54:52)
    2. Preliminary program to be sent later this month (cait, 12:55:06)
    3. Information on hotels and special booking coditions is in the works (cait, 12:56:01)
    4. Presentations will be streamed online, no plans for online workshops yet (cait, 12:58:17)
    5. Registrations will probably open by the end of the month/May (cait, 12:59:46)

  15. Set time of next meeting (cait, 13:00:15)
    1. Next meeting: 17 April 2024, 12 UTC (cait, 13:01:44)


Meeting ended at 13:01:49 UTC (full logs).

Action items

  1. paulderscheid[m] and thd to figure out if the same mail solution as for the wiki can be used
  2. cait to set a date for moving master to main after the hackfest (trying not to break workflows right now)
  3. tcohen to write a guildeline for the API returns when work has gone through QA


Action items, by person

  1. cait
    1. cait to set a date for moving master to main after the hackfest (trying not to break workflows right now)
  2. tcohen
    1. tcohen to write a guildeline for the API returns when work has gone through QA
  3. thd
    1. paulderscheid[m] and thd to figure out if the same mail solution as for the wiki can be used


People present (lines said)

  1. cait (49)
  2. huginn` (6)
  3. caroline (3)
  4. tcohen (2)
  5. thd (1)
  6. kidclamp (1)
  7. fridolin (1)
  8. emlam (1)
  9. EmmiTakkinen[m] (1)
  10. paulderscheid[m] (1)


Generated by MeetBot 0.1.4.