#koha: Development IRC meeting 8 June 2022

Meeting started by tuxayo at 20:59:53 UTC (full logs).

Meeting summary

  1. Introductions (tuxayo, 21:00:00)
    1. Katrin Fischer, BSZ, Germany (cait, 21:00:16)
    2. Victor Grousset, Tuxayo VoG, France (tuxayo, 21:00:48)
    3. Tomas Cohen Arazi, Cordoba, Argentina (tcohen, 21:00:57)
    4. Arthur Suzuki, BibLibre, France (liliputech, 21:01:04)
    5. mason james, nz (mtj, 21:01:57)
    6. Thomas Dukleth, Agogme, New York City (thd, 21:02:50)
    7. https://www.arewewebyet.org/ (tuxayo, 21:04:34)
    8. Thomas Dukleth, Agogme, New York City (thd, 21:04:39)
    9. https://meetings.koha-community.org/2022/development_irc_meeting_25_may_2022.2022-05-25-14.01.html (tuxayo, 21:05:37)
    10. David Nind, New Zealand (davidnind, 21:06:12)

  2. Announcements (tuxayo, 21:06:49)
    1. https://koha-community.org/koha-22-05-released Koha 22.05 released (tuxayo, 21:07:47)
    2. Biblibre is having an internal camp from 27 of june up to 1st of july (cait, 21:10:01)
    3. Need signoff queue is 250, help needed (tuxayo, 21:10:30)
    4. Call for proposals for KohaCon22 closed on Friday 3rd June https://koha-us.org/events/conferences/kohacon22/#tab2 - approximately 21 submissions received (davidnind, 21:10:34)
    5. Fridolin Somers, Biblibre, Tahiti (fridolin, 21:11:53)

  3. Update from the Release manager (22.05) (tuxayo, 21:14:15)
  4. Updates from the Release Maintainers (tuxayo, 21:16:36)
    1. last release of 20.11 went well. I haven't touched 21.05, I will have some catch up on it. (tuxayo, 21:18:48)
    2. keeping up with 22.05.x branch, first time doing a release. hope all is going to be well. (liliputech, 21:20:09)
    3. I will be afk for the whole next week, 21.11.07 might be a little delayed. (liliputech, 21:21:13)
    4. ACTION: tuxayo add requesting access for ssh access for download.koha-community.org in Initial_setup of rmaint doc (tuxayo, 21:26:46)

  5. Updates from the QA team (tuxayo, 21:28:02)
    1. Alex Buckley, Catalyst IT (alexbuckley, 21:28:39)
    2. Omnibus bug for recalls: Bug 29734 - [OMNIBUS] Recalls for Koha (davidnind, 21:33:10)

  6. Status of roadmap projects (tuxayo, 21:33:45)
    1. https://annuel.framapad.org/p/koha_22.11_roadmap Roadmap (tuxayo, 21:34:12)
    2. Tomas in an email: «Feel free to comment there or add the things you plan to work on during this cycle. If there are already bugs filed, please add links to them as well.» (tuxayo, 21:36:03)
    3. Aleisha Amohia, Catalyst IT Wellington New Zealand (aleisha, 21:39:24)

  7. Actions from last meeting (tuxayo, 21:40:43)
  8. General development discussion (trends, ideas, ...) (tuxayo, 21:41:11)
    1. «Status of the LTS release: It looks like we are no longer supporting 19.11, does this mean we have a new "LTS" version now or has the idea been dropped? (LTS workflow proposal)» (tuxayo, 21:41:46)
    2. BibLibre deploys 21.11 to it's clients lately. (liliputech, 21:42:54)
    3. LTS workflow proposal https://wiki.koha-community.org/wiki/LTS_workflow_proposal (davidnind, 21:42:54)
    4. https://hea.koha-community.org/systempreferences show 21.11 has more than 2000 (fridolin, 21:49:55)
    5. Hello, (liliputech, 21:58:58)
    6. https://websvc.afi-sa.net/afi_opac_services/main.php?auteur=Thom+Yorke&width=492&src=c4c56f81d3a566e7c11bf99f78591edc&api=2.0&action=7 (liliputech, 21:58:58)
    7. https://git.afi-sa.net/afi/websvc/-/blob/master/php/fonctions/_define_services.php (liliputech, 21:59:04)
    8. https://git.afi-sa.net/afi/websvc/-/blob/master/README.md (liliputech, 21:59:09)
    9. ACTION: davidnind to create bug to summarise discussions and next steps for LTS version of Koha (davidnind, 22:11:33)
    10. LTS version summary (tuxayo, 22:11:57)
    11. (1) LTS = 2.5 to 3 years (2) Start with oldstable (which is now 21.11) (3) LTS role for each cycle (4) Mandate = security + things that are broken (APIs (external), dependencies (such as Elasticsearch), etc) + essential backports only once past oldoldstable (tuxayo, 22:12:03)
    12. (5) Irregular release - only when something is needed once past oldoldstable (6) Let everyone know what LTS is and what we mean for support (website, mailing list, manual section on supported versions, etc) (tuxayo, 22:12:21)
    13. ACTION: davidnind request feedback for the above on the mailing list with next dev meeting (two weeks from now) as a deadline (tuxayo, 22:16:26)

  9. Gitlab policy changes, register Koha as an Open Source project proper? (tuxayo, 22:18:01)
    1. see email discussion: https://lists.koha-community.org/pipermail/koha-devel/2022-May/047081.html (tuxayo, 22:18:27)
    2. ACTION: tuxayo postpone topic Gitlab policy changes (tuxayo, 22:19:34)

  10. bug Some highlights (tuxayo, 22:19:48)
  11. Some bug highlights (tuxayo, 22:20:02)
    1. Next meeting: 22 June 2022, 14 UTC (tuxayo, 22:33:08)
    2. ACTION: liliputech discuss koha CI (docker image built + manuall build) hosting on gitlab instance provided by BibLibre's partner AFI. (tuxayo, 22:33:52)


Meeting ended at 22:34:43 UTC (full logs).

Action items

  1. tuxayo add requesting access for ssh access for download.koha-community.org in Initial_setup of rmaint doc
  2. davidnind to create bug to summarise discussions and next steps for LTS version of Koha
  3. davidnind request feedback for the above on the mailing list with next dev meeting (two weeks from now) as a deadline
  4. tuxayo postpone topic Gitlab policy changes
  5. liliputech discuss koha CI (docker image built + manuall build) hosting on gitlab instance provided by BibLibre's partner AFI.


Action items, by person

  1. davidnind
    1. davidnind to create bug to summarise discussions and next steps for LTS version of Koha
    2. davidnind request feedback for the above on the mailing list with next dev meeting (two weeks from now) as a deadline
  2. liliputech
    1. liliputech discuss koha CI (docker image built + manuall build) hosting on gitlab instance provided by BibLibre's partner AFI.
  3. tuxayo
    1. tuxayo add requesting access for ssh access for download.koha-community.org in Initial_setup of rmaint doc
    2. tuxayo postpone topic Gitlab policy changes


People present (lines said)

  1. tuxayo (134)
  2. cait (81)
  3. liliputech (71)
  4. davidnind (38)
  5. fridolin (31)
  6. wahanui (8)
  7. huginn (6)
  8. thd (6)
  9. aleisha (6)
  10. rangi[m] (4)
  11. mtj (4)
  12. alexbuckley (3)
  13. tcohen (2)


Generated by MeetBot 0.1.4.